Ga naar inhoud


Foto

ondertitels bij films zetten


47 replies to this topic

#16 JayD

JayD

    Figurant

  • Members
  • 150 Posts:

Gepost 26 december 2010 - 10:09

Het kon niet uitblijven, dus daar gaan we weer.
Het grappige programma VirtualDub vindt het ineens leuk om dwars over de film te zetten dat de demo expired is....
Dus als ik er ondertitels bij wil zetten, staat dat over de hele film.

Ik heb hem er al af gegooid en er een andere versie op gezet, maar dat werkt ook niet.
Enig idee wat dit weer is?

Alvast bedankt.

#17 Aps

Aps

    Film Producent

  • Members
  • 8125 Posts:

Gepost 26 december 2010 - 16:29

Ik dacht dat VirtualDub freeware was..
Heb je VirtualDubMod geprobeerd? Zelfde tool, alleen wat aanpassingen erbij.

http://www.afterdawn...rtualdubmod.cfm

Geposte afbeelding

Voordat je gaat posten lees eerst de regels even door, dat scheelt je een hoop zorgen...


I don`t suffer from insanity - I enjoy every minute of it


#18 JayD

JayD

    Figurant

  • Members
  • 150 Posts:

Gepost 27 december 2010 - 11:23

Ja, ook altijd gedacht dat het gratis was. En in de voorgaande jaren ook nog nooit zoiets gehad.
Staat er ook ergens een handleiding van VirtualDub Mod?
Ik heb hem gedownd, maar er staat al geen audio en de subtitler van Avery Lee is ook ineens verdwenen.
Verder ziet hij er idd redelijk hetzelfde uit.

#19 JayD

JayD

    Figurant

  • Members
  • 150 Posts:

Gepost 27 december 2010 - 11:27

De subtitler heb ik er al instaan, die hoeft niet meer.

#20 JayD

JayD

    Figurant

  • Members
  • 150 Posts:

Gepost 27 december 2010 - 14:16

Het is zo gelukt gelukkig. Audio was hier niet nodig.
In ieder geval nog niet ;)

Bedankt weer!

#21 JayD

JayD

    Figurant

  • Members
  • 150 Posts:

Gepost 19 maart 2011 - 13:55

Zo, het is weer een tijdje geleden, dus het moest er wel bijna van komen.
M'n harde schijf was kapot, dus alles is weer opnieuw geïnstalleerd. Alle codecs die ik zo nog kon vinden, heb ik erin gezet.
Maar de laatste tijd steekt er weer iets anders de kop op. Ik heb me rot gezocht, maar thet zo niet kunnen vinden.
Heb dan ook niet zoveel verstand van computers. Misschien dat het daar aan ligt ;).

Maar het volgende gebeurt: van tijd tot tijd wil ik met VirtualDub Mod ondertitels bij films/series zetten.
De meesten doen het wel, maar bij sommigen krijg ik onderstaande melding:

Virtual Dub has detected an improper VBR audio encoding in the source AVI file (audio stream 1).
The current preference is to rewrite the audio header with standard CBR values during processing for better compatibilitiy.
This may introduce up to 16356 ms of skew from the video stream.
If this is unacceptable, decompress the entire audio stream to an uncompressed WAV file and recompress with a constant bitrate encoder. (bitrate 120.5 (+/-) 15.9 kbps)

Ik kan de ondertiteling er zo wel bij zetten, maar het geluid en het beeld lopen dan niet gelijk.
Moet ik nou iets instellen in VirtualDub, of is daar ook een codec voor?

Alvast bedankt.

Met vriendelijke groet,

John

#22 Astimo

Astimo

    Hoofdrolspeler

  • Members
  • 663 Posts:

Gepost 21 maart 2011 - 22:39

Dat is een extra actie die je dan moet doen. Ik dacht dat ik het bij de hand had, aar helaas, ik moet het op gaan zoeken. Het komt erop neer dat je de audio en de video uit elkaar moet halen, de audio als .wav moet opslaan en bij het branden aangeven dat die bewuste .wav gebruikt moet worden, in plaats van de source audio.
Zodra ik het gevonden heb, laat ik het weten, misschien is er iemand anders die het wel bij de hand heeft.
:)

#23 JayD

JayD

    Figurant

  • Members
  • 150 Posts:

Gepost 01 april 2011 - 09:13

Nou, in ieder geval alvast bedankt. Ik hoop dat iemand het weet,
want nu krijg ik zelfs 2 ondertitels door elkaar, terwijl ik dr mar 1 bijzet.

Niet te begrijpen die programma's.

#24 Opa38

Opa38

    Figurant

  • Members
  • 172 Posts:

Gepost 01 april 2011 - 19:13

Ik weet niet of dit de oplossing is voor je maar ik heb dat ook al een keer gehad.

Wat ik nu doe is de film en de ondertiteling scheiden ik bedoel ik zet ze niet in dezelfde map.

Dus de film laat ik in de map staan en de sub zet ik dan op me buraublad.

Veel sc Opa38
__________________________Geposte afbeelding

#25 JayD

JayD

    Figurant

  • Members
  • 150 Posts:

Gepost 02 april 2011 - 08:16

Dat zal ik eens proberen!

Bedankt ;)

#26 Astimo

Astimo

    Hoofdrolspeler

  • Members
  • 663 Posts:

Gepost 05 april 2011 - 13:19

Aangezien niemand er verder op teruggekomen is, heb ik het nog maar even opgezocht. Bij deze!

1. Open de film in VirtualDub
2. Klik op video en dan op direct stream copy
3. Klik op audio en dan op full processing mode
4. Klik op audio en dan op conversion, en dan op 44.100HZ en High Quality
5. Klik op audio en dan op compression, en dan op ‘No Compression (PCM)’
6. Klik op File en dan op Save WAV

Dan moet je het geluid weer bij de film voegen, want nu heb je het geluid apart opgeslagen:

1. Open de film in VirtualDub
2. Klik op audio en dan op “WAV audio” of ”Audio from other file” (hangt af van de versie van VirtualDub die gebruikt wordt)
3. Selecteer dan het CBR bestand dat je net hebt gemaakt
4. Ga naar Video–>Compression en selecteer de codec Divx MPEG-4 Low-Motion (anders wordt het bestand te groot). Staat de codec DivX MPEG-4 Low-Motion er niet tussen, download dan dit bestand en download de nieuwste versie van de Divx codec. Installeer deze bestanden, en na het opnieuw opstarten van de computer zal de codec DivX MPEG-4 Low-Motion er wel als compressor tussen staan.
5. Ga naar Bestand–>Save as AVI om het bestand op te slaan. Nu zal VirtualDub er een tijdje over doen om de bewerkingen toe te passen en het nieuwe bestand op te slaan. Wanneer het nieuw bestand geopend wordt, zal het geluid weer gelijk lopen met het beeld!

Als het goed is loopt je film nu gelijk met het geluid!
Succes.

En dat je twee ondertitels te zien krijgt, kan ook komen doordat er meerdere weergaveprogrammaatjes (mooi woord!) actief zijn. Als je onder in je statusbalk kijkt, kun je vobsub en misschien nog één zien. Disable één van de twee en je ziet maar één ondertitel.
:)

#27 JayD

JayD

    Figurant

  • Members
  • 150 Posts:

Gepost 06 april 2011 - 12:06

Bedankt voor de grote moeite die je gedaan hebt.
Alleen is het wel zonde dat ik VirtualDub Mod gebruik en daar staat audio nergens bij :P

Maar als ik het probleem vaker heb, dan download ik virtual dub en weet ik wat ik moet doen ;)

Vreemd genoeg zette vd mod de subs er gewoon bij als ik bij die waarschuwing op nee drukte.
Audio liep dan wel gewoon gelijk met het beeld. Heel vreemd allemaal.
En wat de dubbele ondertitels betreft: open ik het in VLC media player dan zijn het dubbele subs,
open ik hem in Windows Media Player dan is het wel goed.

Snapt iemand het nog? :P

Misschien dat anderen er ook iets aan hebben als dit verschijnt.

Nogmaals bedankt voor de moeite!

#28 Astimo

Astimo

    Hoofdrolspeler

  • Members
  • 663 Posts:

Gepost 06 april 2011 - 13:38

Maar als je de waarschuwing negeert en wegdrukt, heb je helemaal geen probleem?
Dan is dat toch de eenvoudigste oplossing?
:)

#29 JayD

JayD

    Figurant

  • Members
  • 150 Posts:

Gepost 07 april 2011 - 15:00

Ja, das zeker ;)

Maar hopen dat dat genoeg blijft.

#30 JayD

JayD

    Figurant

  • Members
  • 150 Posts:

Gepost 27 mei 2011 - 09:27

Het kon ook niet uitblijven. Die PC blijft me maar tegenwerken.
Nu krijg ik weer een melding dat de 3IVX Trial expired is, terwijl ik zoiets nog nooit nodig heb gehad.

Gewoon een film kijken zonder er ondertitels bij te zetten gaat goed, maar als je de ondertitels er dan bij hebt gezet,
krijg je over het hele beeld in het rood 3IVX Trial te zien.
In eerste instantie dacht ik dat het iets te maken had met het programma waarmee ik de fims afspeel,
aangezien het ook te zien was op de pictogrammen.
Maar aangezien ik ze zo wel gewoon kan kijken, weet ik het zo niet.

Iemand een idee wat dit weer is?

Bij voorbaat dank.




0 Gebruiker(s) lezen dit topic

0 gebruikers, 0 gasten, 0 anonieme gebruikers